Change font size


Post a new topicPost a reply Page 1 of 1   [ 6 posts ]
Author Message
 Post subject: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 7:49 pm 
User avatar

Vehicle: JDM SF STi Pure White

Posts: 153
Location: Germany
Hi guys,

when i got my SF, the wheel bearings in the rear were dead. I had them replaced in october.
It was all fine for a while, but now it sounds like it's munched through them again.

I'll get it on a hoist and try to spin the wheels to see if it's really the case of dead bearings.
But if it is, what could be the cause of it? Why would a pair of brand new bearings get destroyed within about four months?


Top
 Profile  
 
 Post subject: Re: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 8:30 pm 
User avatar

I Say: Car mods are like OddBodz, you got to collect them all! -------------------------------------
Vehicle: MY05 STi swapped sled

Posts: 17778
Location: Spearwood Perth WA
Incorrect instalation procedure, or incorrect axle nut torque, or low quality chinese bearings, or you have a bad hub, or the pinch nuts on the axles were not replaced and have un-wound because the pinch part is worn out.

_________________
>>>My Ride<<<


Image


Top
 Profile  
 
 Post subject: Re: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 8:48 pm 
User avatar

Vehicle: JDM SF STi Pure White

Posts: 153
Location: Germany
Hey Bram,

"or you have a bad hub" How can i verify if that is the case or not?
The bearings that i got were ones from a company named STARK. Those are actually more expensive than the Mapco ones that i ordered and paid.

BTW: Don't google image search "pinch nut" unless you want to see a squirrel in a rather peculiar situation.


Top
 Profile  
 
 Post subject: Re: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 9:09 pm 
User avatar

I Say: Car mods are like OddBodz, you got to collect them all! -------------------------------------
Vehicle: MY05 STi swapped sled

Posts: 17778
Location: Spearwood Perth WA
Sometimes the bearing race will actually spin/grind on the hub surface. This is usually quite obvious by the damage.

Sometimes it could be bent. Or it could be out of round. Like if you have hit a curb or if it was overheated from a very bad wheel bearing failure previously.

_________________
>>>My Ride<<<


Image


Top
 Profile  
 
 Post subject: Re: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 9:16 pm 
User avatar

I Say: Up the bum no babies
Vehicle: Undead SH9

Posts: 2409
Location: Cairns, Queensland
I googled pinch nut. Hahaha

_________________
Image

''

Bram wrote:
And the only way for it to fit is with force and ripping flesh


Top
 Profile  
 
 Post subject: Re: SF STi wheel bearings again?
PostPosted: Mon Feb 27, 2017 9:18 pm 
User avatar

I Say: very little. It always gets me into trouble ...
Vehicle: MY07 X MT

Posts: 457
Location: Perth
Phrewfuf wrote:
BTW: Don't google image search "pinch nut" unless you want to see a squirrel in a rather peculiar situation.
You just said that so we all would :lol:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
"Takka LE" for phpBB3